using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"B(?<Seconds>[\d\w]{34})\s";
string input = @"Start File
AXCT XCTrack 0.6.0 - translations: 2017-03-14 17:49:58 on HUAWEI GEM-702L 6.0
HPPLTPILOT:Kay Starkermann
HOSITSite:Schwängimatt
HPCCLCOMPETITION CLASS:FAI-3 (PG)
HPGTYGLIDERTYPE:SKYWALK Spice
HODTM100GPSDATUM:WGS-84
HFALG:GEO
HFDTE060417
LXCTDEVICE eyJjYXBhYmlsaXRpZXMiOnsibWVtQ2xhc3MiOjI1NiwibWVtTGFyZ2VDbGFzcyI6M
LXCTDEVICE jU2LCJuYW4iOnRydWV9LCJkZXZpY2UiOnsiYW5kcm9pZElkIjoiMzRhM2Q1MzBhZm
LXCTDEVICE I4YmViYyIsImJvYXJkIjoiR0VNLTcwMkwiLCJidWlsZElkIjoiSFVBV0VJR0VNLTc
LXCTDEVICE wMkwiLCJjcHVBQkkiOiJhcm02NC12OGEiLCJjcHVBQkkyIjoiIiwiZGV2aWNlU3Ry
LXCTDEVICE aW5nIjoiSFVBV0VJIEdFTS03MDJMIDYuMCIsImRpc3BsYXkiOnsiaCI6MTg0OCwib
LXCTDEVICE W0iOjE1Ljc0ODAzMiwidyI6MTIwMH0sImZpbmdlcnByaW50IjoiSFVBV0VJL0dFTS
LXCTDEVICE 03MDJML0hXR2VtaW5pOjYuMC9IVUFXRUlHRU0tNzAyTC9DMjA5QjIwMzp1c2VyL3J
LXCTDEVICE lbGVhc2Uta2V5cyIsImhhcmR3YXJlIjoiaGkzNjM1IiwibWFudWZhY3R1cmVyIjoi
LXCTDEVICE SFVBV0VJIiwicHJvZHVjdCI6IkdFTS03MDJMIiwic2RrIjoyM30sInhjdHJhY2siO
LXCTDEVICE nsidmVyc2lvbkNvZGUiOjYzLCJ2ZXJzaW9uTmFtZSI6IjAuNi4wIC0gdHJhbnNsYX
LXCTDEVICE Rpb25zOiAyMDE3LTAzLTE0IDE3OjQ5OjU4In19
LXCTSENSOR Sensors: SENSOR_BT, external GPS:true, external baro:true, intern
LXCTSENSOR al baro:false
LXCTEARTHMODEL FAI_SPHERE
B1505404717336N00740471EA0101001091
B1505414717336N00740472EA0101001091
B1505424717335N00740472EA0101001091
B1505434717336N00740472EA0101001090
B1505444717336N00740472EA0100901090
B1505454717336N00740471EA0100901091
B1505464717336N00740471EA0101001091
B1505474717336N00740471EA0101001091
B1505484717336N00740471EA0101001091
B1505494717336N00740471EA0101001091
B1505504717336N00740471EA0101001091
B1505514717336N00740471EA0101001091
End File";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}