import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([0-9]+|[a-z]+|[A-Z]+)\\,([0-9]+|[a-z]+|[A-Z]+)\"";
final String string = "lorem, ipsum\n"
+ "\"5,25\", foobar\n"
+ "\"foo,bar\", foobar\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}