re = /"([0-9]+|[a-z]+|[A-Z]+)\,([0-9]+|[a-z]+|[A-Z]+)"/m
str = 'lorem, ipsum
"5,25", foobar
"foo,bar", foobar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end