#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(dont.*done.*?\K)?(dont(?!.*done).*(*SKIP)(*FAIL))?mul"
Local $sString = "mul mul dont mul mul done mul mul" & @CRLF & _
"" & @CRLF & _
"mul mul done mul mul" & @CRLF & _
"mul mul dont mul mul" & @CRLF & _
"mul mul done mul mul dont mul mul"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")