re = /(dont.*done.*?\K)?(dont(?!.*done).*(*SKIP)(*FAIL))?mul/m
str = 'mul mul dont mul mul done mul mul
mul mul done mul mul
mul mul dont mul mul
mul mul done mul mul dont mul mul'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end