using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-TV-Z|a-tv-z|\d])([\d])([A-TV-Z|a-tv-z|\d])(.?)([A-TV-Z|a-tv-z|\d]{0,4})$";
string input = @"S62.0XX6
99.2
095.20
9S6
E27.09xx66
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}