const regex = /^([A-TV-Z|a-tv-z|\d])([\d])([A-TV-Z|a-tv-z|\d])(.?)([A-TV-Z|a-tv-z|\d]{0,4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-TV-Z|a-tv-z|\\d])([\\d])([A-TV-Z|a-tv-z|\\d])(.?)([A-TV-Z|a-tv-z|\\d]{0,4})$', 'gm')
const str = `S62.0XX6
99.2
095.20
9S6
E27.09xx66
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}