package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^][_]*)]`)
var str = `Line 1: [String] returns String
Line 2: [String_Ab] returns String_AB.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}