$re = '/\[([^][_]*)]/m';
$str = 'Line 1: [String] returns String
Line 2: [String_Ab] returns String_AB.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);