const regex = /CHANGE.+(?=SHOES.+(?!NIKE))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CHANGE.+(?=SHOES.+(?!NIKE))', 'gm')
const str = `
CHANGE OF SHOES TO NIKE AIRS.
CHANGE THE SHOES TO REBOOK.
CHANGE PANTS AND SHOES TO ADIDAS WOMENS
CHANGE.+(?=SHOES).+(?!NIKE).+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}