$re = '/CHANGE.+(?=SHOES.+(?!NIKE))/m';
$str = '
CHANGE OF SHOES TO NIKE AIRS.
CHANGE THE SHOES TO REBOOK.
CHANGE PANTS AND SHOES TO ADIDAS WOMENS
CHANGE.+(?=SHOES).+(?!NIKE).+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);