re = /(http|www|file)\S+/m
str = '!play https://www.youtube.com/watch?v=tXGobgt-1Jg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end