package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:0?[1-9]|1[012])[- /.](?:0?[1-9]|[12][0-9]|3[01])[- /.](?:19|20)\d\d\b`)
var str = `03/04/1991
3/04/1991
03/4/1991`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}