re = /\b(?:0?[1-9]|1[012])[- \/.](?:0?[1-9]|[12][0-9]|3[01])[- \/.](?:19|20)\d\d\b/m
str = '03/04/1991
3/04/1991
03/4/1991'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end