package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+?[(]?(?:[0-9\ ][a-z]?[()\-\.]?){3,}`)
var str = `+1-023-999-982`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}