import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=.*[a-z])(?=.*[A-Z])|(?=.*[a-z])(?=.*[\\d])|(?=.*[A-Z])(?=.*[\\d])|(?=.*[!#+,.\\\\=:=@-])(?=.*[\\d])|(?=.*[!#+,.\\\\=:=@-])(?=.*[a-z])|(?=.*[!#+,.\\\\=:=@-])(?=.*[A-Z])).+$";
final String string = "aaaa\n"
+ "DDDD\n"
+ "1234\n"
+ "aaBB\n"
+ "aa12\n"
+ "AA11\n"
+ "##22\n"
+ "##ab\n"
+ "@@AA\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}