$re = '/^(?:(?=.*[a-z])(?=.*[A-Z])|(?=.*[a-z])(?=.*[\d])|(?=.*[A-Z])(?=.*[\d])|(?=.*[!#+,.\\\\=:=@-])(?=.*[\d])|(?=.*[!#+,.\\\\=:=@-])(?=.*[a-z])|(?=.*[!#+,.\\\\=:=@-])(?=.*[A-Z])).+$/m';
$str = 'aaaa
DDDD
1234
aaBB
aa12
AA11
##22
##ab
@@AA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);