re = /\b\d+(?=,)/m
str = 'Witkin & Epstein, Criminal Law (3d ed), Pretrial Proceedings §§ 10, 438,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end