package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)option="(.+)"`)
var str = `option="primary"
option="secondary"
option="thirdary??"
option="quarterly"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}