re = /option="(.+)"/m
str = 'option="primary"
option="secondary"
option="thirdary??"
option="quarterly"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end