$re = '/\'[^\']*(?:\'\'[^\']*)*\'/m';
$str = '- "his \'pet\'\'s name is tom\' and she is 2 years old"
- "\'\'\'\'"
- "\'\'"
- "function(\'name\', test, \'age\')"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);