re = /'[^']*(?:''[^']*)*'/m
str = '- "his \'pet\'\'s name is tom\' and she is 2 years old"
- "\'\'\'\'"
- "\'\'"
- "function(\'name\', test, \'age\')"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end