package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+)\s(\(.+\))`)
var str = `ABC (US)
ABC (AU)
CBC (CA)
Sky Atlantic (UK)
Comedy Central (US)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}