$re = '/(.+)\s(\(.+\))/m';
$str = 'ABC (US)
ABC (AU)
CBC (CA)
Sky Atlantic (UK)
Comedy Central (US)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);