$re = '/[+()\d].*?\d{4}(?!\d)/';
$str = '(123) 456-7890 or (123)456-7890 or 1234567890 or "123.456.7890" or "123 456 7890"
1-234-567-8901
1 (234) 567-8901
1.234.567.8901
1/234/567/8901
12345678901
1 (234) 567-8901
1.234.567.8901
1/234/567/8901
(+55) 12345678901
+551234567890';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;