import Foundation
let pattern = #"[+()\d].*?\d{4}(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(123) 456-7890 or (123)456-7890 or 1234567890 or "123.456.7890" or "123 456 7890"
1-234-567-8901
1 (234) 567-8901
1.234.567.8901
1/234/567/8901
12345678901
1 (234) 567-8901
1.234.567.8901
1/234/567/8901
(+55) 12345678901
+551234567890
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)