#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?=.*logo)(?:https)?:\/\/\S+(?:png|jpe?g|gif|tiff)$"
Local $sString = "https://static.infragistics.com/marketing/Website/home/espn-logo.png" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/mondelez-logo.gif" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/nielsen-logo.jpg" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/united-logo.jpeg" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/merrill-lynch-logo.PNG" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/dell-logo.TIFF" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/intel-logo.gif" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/prudential-logo.png" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/mcdonalds-logo.GIF" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/mcdonalds-alogo.GIF" & @CRLF & _
"https://static.infragistics.com/marketing/Website/home/mcdonalds-logos.GIF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")