import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?=.*logo)(?:https)?:\\/\\/\\S+(?:png|jpe?g|gif|tiff)$";
final String string = "https://static.infragistics.com/marketing/Website/home/espn-logo.png\n"
+ "https://static.infragistics.com/marketing/Website/home/mondelez-logo.gif\n"
+ "https://static.infragistics.com/marketing/Website/home/nielsen-logo.jpg\n"
+ "https://static.infragistics.com/marketing/Website/home/united-logo.jpeg\n"
+ "https://static.infragistics.com/marketing/Website/home/merrill-lynch-logo.PNG\n"
+ "https://static.infragistics.com/marketing/Website/home/dell-logo.TIFF\n"
+ "https://static.infragistics.com/marketing/Website/home/intel-logo.gif\n"
+ "https://static.infragistics.com/marketing/Website/home/prudential-logo.png\n"
+ "https://static.infragistics.com/marketing/Website/home/mcdonalds-logo.GIF\n"
+ "https://static.infragistics.com/marketing/Website/home/mcdonalds-alogo.GIF\n"
+ "https://static.infragistics.com/marketing/Website/home/mcdonalds-logos.GIF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}