import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\p{L} '.-]+?(?=(?:\\s[a-z]+)*\\h*$)";
final String string = "John Doe waves \n"
+ "Bakary N'Diaye says hello \n"
+ "Iván Aguilar goes well \n"
+ "Cisteró shot \n"
+ "Dan I Soylu shots \n"
+ "Mike van der Hoorn with a cross \n"
+ "M.J. Williams takes a shot \n"
+ "Donny van de Beek left foot \n"
+ "Mike van der Hoorn hello \n"
+ "Artak G. Grigoryan with through ball \n"
+ "Trent Alexander-Arnold after a break \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}