# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\p{L} '.-]+?(?=(?:\s[a-z]+)*\h*$)"
test_str = ("John Doe waves \n"
"Bakary N'Diaye says hello \n"
"Iván Aguilar goes well \n"
"Cisteró shot \n"
"Dan I Soylu shots \n"
"Mike van der Hoorn with a cross \n"
"M.J. Williams takes a shot \n"
"Donny van de Beek left foot \n"
"Mike van der Hoorn hello \n"
"Artak G. Grigoryan with through ball \n"
"Trent Alexander-Arnold after a break \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.