const regex = /^(development|master|main|(((features|tests|bugfix|hotfix)\/(([0-9A-Za-z-_]+)|((\/[0-9A-Za-z-_]+)))|release\/(?:(\d+)\.)?(?:(\d+)\.)?(\d+)?(-(alpha|beta|rc)[0-9]))))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(development|master|main|(((features|tests|bugfix|hotfix)\\\/(([0-9A-Za-z-_]+)|((\\\/[0-9A-Za-z-_]+)))|release\\\/(?:(\\d+)\\.)?(?:(\\d+)\\.)?(\\d+)?(-(alpha|beta|rc)[0-9]))))', 'gm')
const str = `development
main
bugfix/user-list
bugfix/user_list
bugfix/123
bugfix/123/account-update
bugfix/123/account_update
bugfix/User_crud/account-update
bugfix/User_crud/account_update
tests/api
tests/123
tests/123/hello
release/1.0.1
release/1.0.1-beta1
release/1.0.1-beta
release/1.0.1-rc3
it should not match following
bugfix/
bugfix/-
bugfix/_
bugfix/-name
bugfix/_name
bugfix/-/name
bugfix/-/-
bugfix/-/_
release/v1.0.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}