# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(development|master|main|(((features|tests|bugfix|hotfix)\/(([0-9A-Za-z-_]+)|((\/[0-9A-Za-z-_]+)))|release\/(?:(\d+)\.)?(?:(\d+)\.)?(\d+)?(-(alpha|beta|rc)[0-9]))))"
test_str = ("development\n"
"main\n"
"bugfix/user-list\n"
"bugfix/user_list\n"
"bugfix/123\n"
"bugfix/123/account-update\n"
"bugfix/123/account_update\n"
"bugfix/User_crud/account-update\n"
"bugfix/User_crud/account_update\n"
"tests/api\n"
"tests/123\n"
"tests/123/hello\n"
"release/1.0.1\n"
"release/1.0.1-beta1\n"
"release/1.0.1-beta\n"
"release/1.0.1-rc3\n\n\n"
"it should not match following\n"
"bugfix/\n"
"bugfix/-\n"
"bugfix/_\n"
"bugfix/-name\n"
"bugfix/_name\n"
"bugfix/-/name\n"
"bugfix/-/-\n"
"bugfix/-/_\n"
"release/v1.0.1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.