package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^(\/\/.*(\n\/\/.*|\n)*)$)|(^\/\*([^*]|(\*+([^*/]|$)))*\*+\/(\n\/\/.*|\n)*$)`)
var str = `/*Yorum satırı*/
//yorum satırı
///yorum satırı`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}