re = /(^(\/\/.*(\n\/\/.*|\n)*)$)|(^\/\*([^*]|(\*+([^*\/]|$)))*\*+\/(\n\/\/.*|\n)*$)/
str = '/*Yorum satırı*/
//yorum satırı
///yorum satırı'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end