$re = '/(?<=Jinja..Linter.Version.v)[0-9]+([.][0-9]+)*/m';
$str = 'Jinja2-Linter Version v1.2.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);