$re = '/Symfony\s\d{1}.*/m';
$str = 'Symfony 4.4.3 (env: dev, debug: true)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);