package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`}(\r\n?|\n).*(\r\n?|\n).*}(\r\n?|\n|$)`)
var str = `está no fim da linha -> }
qualquer texto, \" blablá etc
linha } <- não está no final da linha, deve pular
está no fim da linha, mas tem mais de uma linha entre esse e o primeiro }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \" blablá etc
asdasdasasdsa
fim da linha -> }
apenas uma linha, \", á´bcetc
esse vai pegar }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}