const regex = /}(\r\n?|\n).*(\r\n?|\n).*}(\r\n?|\n|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('}(\\r\\n?|\\n).*(\\r\\n?|\\n).*}(\\r\\n?|\\n|$)', 'g')
const str = `está no fim da linha -> }
qualquer texto, \\" blablá etc
linha } <- não está no final da linha, deve pular
está no fim da linha, mas tem mais de uma linha entre esse e o primeiro }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \\" blablá etc
asdasdasasdsa
fim da linha -> }
apenas uma linha, \\", á´bcetc
esse vai pegar }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}