import re
regex = re.compile(r"^(?!021|031)\d*", flags=re.MULTILINE)
test_str = ("022 123-456-2322\n"
"021 123-456-2322\n"
"031 123-456-2377\n"
"041 123-456-2322\n"
"021 555-456-2322\n"
"031 555-456-2322\n"
"0341 555-456-2322\n"
"021 123-456-2377\n"
"0341 123-456-2377\n"
"0341 123-021-2377\n"
"0341 123-031-2377")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")