re = /^(?!021|031)\d*/m
str = '022 123-456-2322
021 123-456-2322
031 123-456-2377
041 123-456-2322
021 555-456-2322
031 555-456-2322
0341 555-456-2322
021 123-456-2377
0341 123-456-2377
0341 123-021-2377
0341 123-031-2377'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end