$re = '/(?<!\d)\d*[13579](?!\d)/m';
$str = 'The number 13 matches
1
2
3
4
5
6
7
8
9
10
100
134
136
157
12355
65448';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);