re = /(?<!\d)\d*[13579](?!\d)/m
str = 'The number 13 matches
1
2
3
4
5
6
7
8
9
10
100
134
136
157
12355
65448'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end