package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(0020).\`)
var str = `0020 [id:310020]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}