$re = '/(0020).\/m';
$str = '0020 [id:310020]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);