using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^(?:.*a){3}.*$)(?=^(?:.*b){3}.*$)(?=^(?:.*c){3}.*$|^[^c]*$).*";
string input = @"aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbbc
aabbb
abbccc
abcabca";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}