const regex = new RegExp('(?i)(?<=\\b)(?:(\\w{1,3})(?:-|\\.{2,10})[\\t\\f ]?)+(\\1\\w{2,})', 'g')
const str = `"Erm....yes. Thank you for that."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}