re = /(?i)(?<=\b)(?:(\w{1,3})(?:-|\.{2,10})[\t\f ]?)+(\1\w{2,})/
str = '"Erm....yes. Thank you for that."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end