$re = '/(?=\b((?:\p{Alnum}+\p{Punct}){2}\p{Alnum}+)\b)/m';
$str = 'https://www.google.com.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);