re = /(?=\b((?:\p{Alnum}+\p{Punct}){2}\p{Alnum}+)\b)/m
str = 'https://www.google.com.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end