$re = '/\w+(?:\.\w+)+/m';
$str = 'TD#{test1.test.test3234.rsatars.23432i.rstrsti.arstarst}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);